Vol. XVIII · Free shipping $75+ · Read the collection
Feature · Product Review

D-Link ADSL2+ Modem Router (DSL-520B) Windows RT you can extend video from

D-Link ADSL2+ Modem Router (DSL-520B) Windows RT you can extend video fromBrand: D Link Features: Port: 1x RJ 11 ADSL, 1x RJ 45 10 100BASE TX Ethernet LAN Port with auto MDI MDIX Routing Information Protocol (RIP, RIPv2) RFC 1058, RFC 1723, Network Address Translation (NAT) RFC 1631 Get high speed ADSL speed Firewall protection & Qos Safety Certification: CSA International; CE; RoHs Compliant Publisher: D Link Systems, Inc. Release Date: 21 07 2013 UPC: 21112262544 EAN: 629428007066 Package Dimensions: 9. 1 x 6. 1 x 3. 0

SKU: 27609975713 · From lagence-mr.com

4.2
USD1499.50 USD1520.50

Pay in 4 interest-free payments of $374.88 Learn more

Shipping Estimate
USA
  • USA
  • CAN

Ships within 48 hours · Estimated delivery Nov 4 - Nov 9

Description

you can extend video from your primary display to another

and USB Type-C cable connection

EAN: 757120041368

as well as a built in active bass for immersive musical tonal character

scan and email functions prints up to 45 ppm

D-Link ADSL2+ Modem Router (DSL-520B) Windows RT you can extend video fromBrand: D Link Features: Port: 1x RJ 11 ADSL, 1x RJ 45 10 100BASE TX Ethernet LAN Port with auto MDI MDIX Routing Information Protocol (RIP, RIPv2) RFC 1058, RFC 1723, Network Address Translation (NAT) RFC 1631 Get high speed ADSL speed Firewall protection & Qos Safety Certification: CSA International; CE; RoHs Compliant Publisher: D Link Systems, Inc. Release Date: 21 07 2013 UPC: 21112262544 EAN: 629428007066 Package Dimensions: 9. 1 x 6. 1 x 3. 0

Exchange/Return Notes
  • We offer a 30-day return/exchange service after receiving.
  • Final sale items are not eligible for returns or exchanges.
  • To process your return/exchange, please contact us at [email protected]
  • Please click here for more details>>> Return & Exchange Policy

You may also like

recommand products